IModelConnection
Classes for working with a connection to an iModel briefcase
Classes
Name | Description | |
---|---|---|
BlankConnection | A connection that exists without an iModel. | |
BriefcaseConnection | A connection to an editable briefcase on the backend. | |
BriefcaseEditorToolSettings | Settings that can be used to control the behavior of Tools that modify a BriefcaseConnection. | |
BriefcaseNotificationHandler | Base class for notification handlers for events from the backend that are specific to a BriefcaseConnection. | |
BriefcaseTxns | Manages local changes to a BriefcaseConnection via Txns. | |
CheckpointConnection | An IModelConnection to a Checkpoint of an iModel. | |
EntityChanges | Describes a set of elements or models that were modified as part of a transaction in a BriefcaseConnection, | |
GeoConverter | An object capable of communicating with the backend to convert between coordinates in a geographic coordinate system and coordinates in an IModelConnection's own coordinate system. | |
GeoServices | The Geographic Services available for an IModelConnection. | |
GraphicalEditingScope | Represents a period of time within an interactive editing session during which the | |
IModelConnection | A connection to a IModelDb hosted on the backend. | |
IModelRoutingContext | Controls the RPC routing for an iModel connection. | |
Metadata | Describes the BIS class of a TxnEntityChange. | |
SnapshotConnection | A connection to a SnapshotDb hosted on a backend. | |
Tiles | Provides access to TileTrees associated with an IModelConnection. |
Interfaces
Name | Description | |
---|---|---|
BlankConnectionProps | The properties for creating a Blank IModelConnection | |
DownloadProgressInfo | Download progress information. | |
GenericAbortSignal | Partial interface of AbortSignal. | |
PullChangesOptions | Options for pulling iModel changes. | |
TxnEntityChange | Represents a single change to a single Entity, as part of a collection of TxnEntityChanges. | |
TxnEntityChanges | Describes a set of elements or models that were modified as part of a transaction in a BriefcaseConnection, | |
TxnEntityChangesFilterOptions | Options defining criteria by which to filter the contents of a TxnEntityChanges. | |
TxnEntityMetadata | Describes the BIS class of a TxnEntityChange. |
Namespaces
Name | Description | |
---|---|---|
IModelConnection |
Type Aliases
Name | Description | |
---|---|---|
OnDownloadProgress | Called to show progress during a download. | |
TxnEntityChangeIterable | A collection of TxnEntityChanges. | |
TxnEntityChangeType | The type of operation that produced a TxnEntityChange. | |
TxnEntityMetadataCriterion | A function that returns true if a particular BIS Entity class should be included when iterating a TxnEntityChangeIterable. |
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.