Frontstage
Classes for working with a Frontstage
Classes
Name | Description | |
---|---|---|
FrontstageActivatedEvent | Frontstage Activated Event class. | Deprecated |
FrontstageDeactivatedEvent | Frontstage Deactivated Event class. | Deprecated |
FrontstageDef | FrontstageDef class provides an API for a Frontstage. | |
FrontstageProvider | Provides a definition required to create a Frontstage. | Deprecated |
FrontstageReadyEvent | Frontstage Ready Event class. | Deprecated |
ModalFrontstage | ModalFrontstage React component | |
ModalFrontstageChangedEvent | Modal Frontstage Stack Changed Event class. | Deprecated |
ModalFrontstageClosedEvent | Modal Frontstage Closed Event class. | Deprecated |
NestedFrontstage | Nested Frontstage related classes and commands | Deprecated |
PanelStateChangedEvent | Panel state changed event class. | Deprecated |
SettingsModalFrontstage | Modal frontstage displaying and editing settings from registered settings providers. | |
StagePanelDef | A StagePanelDef represents each Stage Panel within a Frontstage. | |
StandardFrontstageProvider | FrontstageProvider that provides an "empty" stage. | Deprecated |
ToolActivatedEvent | Tool Activated Event class. | Deprecated |
ToolIconChangedEvent | Tool Icon Changed Event class. | Deprecated |
Enumerations
Name | Description | |
---|---|---|
SelectionScope | Selection Scope enum. | |
StagePanelLocation | Available Stage Panel locations. | |
StagePanelSection | Enum for Stage Panel Sections | |
StagePanelState | Enum for StagePanel state. |
Global Functions
Name | Description | |
---|---|---|
NestedFrontstageAppButton | App button used in a nested frontstage. | |
useActiveFrontstageDef | Hook to return the active Frontstage def. | |
useActiveFrontstageId | Hook that returns active frontstage id. | |
useSpecificWidgetDef | Hook that returns the widgetDef for a specific widgetId within the active frontstage. |
Interfaces
Name | Description | |
---|---|---|
FrameworkFrontstages | frontstages interface | |
FrontstageActivatedEventArgs | Frontstage Activated Event Args interface. | Deprecated |
FrontstageConfig | Configuration from which a frontstage is created. | Deprecated |
FrontstageDeactivatedEventArgs | Frontstage Deactivated Event Args interface. | Deprecated |
FrontstageReadyEventArgs | Frontstage Ready Event Args interface. | Deprecated |
ModalFrontstageChangedEventArgs | Modal Frontstage Changed Event Args interface. | Deprecated |
ModalFrontstageClosedEventArgs | Modal Frontstage Closed Event Args interface. | Deprecated |
ModalFrontstageInfo | Modal Frontstage information interface. | |
ModalFrontstageProps | Properties for the ModalFrontstage React component | |
PanelPinnedChangedEventArgs | Panel pinned changed event args interface. | Deprecated |
PanelStateChangedEventArgs | Panel state changed event args interface. | Deprecated |
StagePanelConfig | Configuration from which a stage panel is created. | |
StagePanelSectionsConfig | Configuration from which stage panel sections are created. | |
StandardFrontstageProps | Props of a StandardFrontstageProvider. | |
ToolActivatedEventArgs | Tool Activated Event Args interface. | Deprecated |
ToolIconChangedEventArgs | Tool Icon Changed Event Args interface. | Deprecated |
Namespaces
Name | Description | |
---|---|---|
FrontstageUtilities | Helper namespace to create frontstages. |
Type Aliases
Name | Description | |
---|---|---|
Frontstage | Configuration from which a frontstage is created. | |
StagePanelMaxSizeSpec | Available units of panel max size. | Deprecated |
StagePanelSectionConfig | Configuration from which a stage panel section is created. | |
StagePanelSizeSpec | Available units of panel size - pixels or percentage of app size. | |
WidgetPanelProps | Widget panel properties used in a StandardFrontstageProps. |
Last Updated: 07 August, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.