Tools
Core Tool definitions
Classes
Name | Description | |
---|---|---|
CoreTools | Utility Class that provides definitions of tools provided by the core-frontend core. | Deprecated |
FrameworkToolAdmin | Subclass of ToolAdmin in @itwin/core-frontend to be used to initialize IModelApp . |
|
HideIsolateEmphasizeActionHandler | Interface for class that handles Hide, Isolate, and Emphasize Actions | |
HideIsolateEmphasizeManager | Provides helper functions for doing commands on logical selection like categories and subjects. | |
RestoreAllFrontstagesTool | Immediate tool that will reset the layout of all frontstages to that specified in the stage definition. | |
RestoreFrontstageLayoutTool | Immediate tool that will reset the layout to that specified in the stage definition. | |
SelectionContextToolDefinitions | Utility Class that provides definitions for tools dependent on current selection. | Deprecated |
Enumerations
Name | Description | |
---|---|---|
HideIsolateEmphasizeAction | Supported Hide, Isolate, and Emphasize Actions. | |
KeyinFieldLocalization | Controls whether localized and/or non-localized key-in strings appear in a KeyinField's auto-completion list. |
Global Functions
Name | Description | |
---|---|---|
areNoFeatureOverridesActive | Return ConditionalBooleanValue object used to show items if selection set is active. | Deprecated |
featureOverridesActiveStateFunc | Return state with isVisible set to true is SectionSet is active. | Deprecated |
getFeatureOverrideSyncEventIds | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
getIsHiddenIfFeatureOverridesActive | Return ConditionalBooleanValue object used to show item if feature overrides are active. | Deprecated |
getIsHiddenIfSelectionNotActive | Return ConditionalBooleanValue object used to show items if selection set is active. | Deprecated |
getSelectionContextSyncEventIds | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
isNoSelectionActive | Return SyncEventIds that trigger selection state function refresh. | Deprecated |
selectionContextStateFunc | Return state with isVisible set to true is SectionSet is active. | Deprecated |
Interfaces
Name | Description | |
---|---|---|
EmphasizeElementsChangedArgs | Selection Context Action Event Argument | |
KeyinEntry | Defines a keyin entry to show/filter in UI |
Namespaces
Name | Description | |
---|---|---|
ToolbarItems | Helper namespace to create commonly used toolbar items. |
Last Updated: 28 June, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.