Utils
Miscellaneous utility classes.
Global Functions
Name | Description | |
---|---|---|
calculateSolarAngles | calculate solar angles (in radians) based at a given date/time and cartographic location. | |
calculateSolarDirection | calculate solar direction based at a given date/time and cartpgrphic location. | |
calculateSolarDirectionFromAngles | calculate solar direction corresponding to the given azimuth and elevation (altitude) angles in degrees. | |
calculateSunriseOrSunset | calculate solar sunrise or sunset for a given day and cartographic location. |
Interfaces
Name | Description | |
---|---|---|
GenericInstanceFilter | Generic instance filter that has all the necessary information to build filtering query. | |
GenericInstanceFilterRelatedInstanceDescription | Describes related instance whose property was used in the filter. | |
GenericInstanceFilterRelationshipStep | Describes single step between source class and target class. | |
GenericInstanceFilterRule | Defines single filter rule. | |
GenericInstanceFilterRuleGroup | Group of filter rules joined by logical operator. |
Namespaces
Name | Description | |
---|---|---|
GenericInstanceFilter | ||
GenericInstanceFilterRuleValue |
Type Aliases
Name | Description | |
---|---|---|
BackendReadable | Deprecated | |
BackendWritable | Deprecated | |
GenericInstanceFilterRuleGroupOperator | Type definition that describes operators supported by GenericInstanceFilterRuleGroup. | |
GenericInstanceFilterRuleOperator | Type definition that describes operators supported by GenericInstanceFilterRule. | |
GenericInstanceFilterRuleValue | Type definition that describes value of GenericInstanceFilterRule. |
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.