connector-framework
Classes
Name | Description | |
---|---|---|
BaseConnector | Abstract implementation of the iTwin Connector. | |
CallbackClient | A special implematation of an AuthorizationClient whose constructor takes a single tokenCallback. | |
CallbackUrlClient | A special implementation of a CachedTokenClient whose constructor takes a single callback URL. | |
ChangeSetGroup | Class to represent a ChangeSetGroup | |
ConnectorAuthenticationManager | ||
ConnectorRunner | ||
DummyCallbackUrlClient | A special implementation of a CachedTokenClient whose constructor takes a single callback URL. | |
Fetcher | Fetcher | |
HubArgs | Arguments specific to iModelHub used in a connector job | |
JobArgs | Arguments specific to a connector job | |
SqliteIssueReporter | SQLite issue reporter. | |
Synchronizer | Helper class for interacting with the iModelDb during synchronization. |
Enumerations
Name | Description | |
---|---|---|
ItemState | The state of the given SourceItem against the iModelDb | |
LoggerCategories | Logger categories used by this package |
Global Functions
Name | Description | |
---|---|---|
getSyncError | @description: looks up the structured error by key and populates the SyncError object |
Interfaces
Name | Description | |
---|---|---|
AllArgsProps | Defines the schema of the .json argument file used to initialize ConnectorRunner | |
ChangeResults | ||
ConnectorIssueReporter | Abstract implementation of the Issue Reporter | |
DeletionDetectionParams | paramaters to control how deletions are detected. | |
DocumentProperties | Properties that may be assigned to a document by its home document control system | |
DummyCallbackUrlParams | ||
ErrorReport | @description: The ErrorReport interface represents the structure of the Syncerr.json file | |
FetcherParams | FetcherParams | |
HubArgsProps | ||
JobArgsProps | ||
RecordDocumentResults | ||
SourceDocument | Identifies an external document and its state. | |
SourceItem | A SourceItem identifies an entity in an external source and the state of the content of the entity. |
|
SyncError | @description: The SyncError interface represents the structure of a single error in the Syncerr.json file | |
SynchronizationResults |
Namespaces
Name | Description | |
---|---|---|
SyncErrors |
Type Aliases
Name | Description | |
---|---|---|
AccessTokenCallbackUrl | ||
AccessTokenGetter | ||
ConnectRegion | ||
PostPublishingProcessor |
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.