SourceDocument Interface
Identifies an external document and its state. This data is stored in the ExternalSourceAspect of the RepositoryLink Element that represents the document. The ExternalSourceAspect tracks the source document.
Methods
Name | Description | |
---|---|---|
checksum(): undefined | string Optional | The cryptographic hash (any algorithm) of the document's content. |
Properties
Name | Type | Description | |
---|---|---|---|
description | string | undefined | A human-readable description of the source document. | |
docProps | DocumentProperties | undefined | Additional properties that may be assigned to the document by the document management system. | |
docid | string | The stable unique ID of the source document. | |
lastModifiedTime | string | undefined | An optional value that is typically the last modified time of the document. |
Defined in
- Synchronizer.ts Line 137
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.