Name |
Description |
|
CalloutProps |
|
|
CategoryProps |
Parameters of a Category |
|
ChangedElements |
Changed elements found in a changeset or between a range of changesets. |
|
ChannelRootAspectProps |
Properties of an ChannelRootAspect that identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained. |
|
CustomAttribute |
A custom attribute instance |
|
DefinitionElementProps |
Properties of a DefinitionElement |
|
DisplayStyleLoadProps |
Options controlling which properties are included or excluded when querying DisplayStyleProps. |
|
ElementAspectProps |
Properties of an ElementAspect |
|
ElementLoadOptions |
Options used to specify properties to include or exclude when querying ElementProps with functions like |
|
ElementLoadProps |
Parameters to specify what element to load for functions like IModelDb.Elements.getElementProps. |
|
ElementProps |
Properties of an Element |
|
EntityMetaDataProps |
|
|
EntityProps |
The persistent format of an Entity, also used as the "wire format" when transmitting information about entities |
|
EntityQueryParams |
Parameters for performing a query on Entity classes. |
|
ExternalSourceAspectProps |
Properties of an ExternalSourceAspect that stores synchronization information for an element originating from an external source. |
|
ExternalSourceAttachmentProps |
Properties of an ExternalSourceAttachment |
|
ExternalSourceProps |
Properties of an ExternalSource |
|
FunctionalElementProps |
|
|
GeometricElement2dProps |
Properties that define a GeometricElement2d |
|
GeometricElement3dProps |
Properties that define a GeometricElement3d |
|
GeometricElementProps |
Properties of a GeometricElement |
|
GeometricModel2dProps |
Properties that define a GeometricModel2d |
|
GeometricModel3dProps |
Properties that define a GeometricModel3d |
|
GeometricModelProps |
Properties that describe a GeometricModel |
|
GeometryPartProps |
Properties of a GeometryPart |
|
InformationPartitionElementProps |
Properties of a InformationPartitionElement |
|
LineStyleProps |
Properties of a LineStyle |
|
ModelLoadProps |
Properties that specify what model should be loaded. |
|
ModelProps |
Properties that define a Model |
|
ModelQueryParams |
Parameters for performing a query on Model classes. |
|
PhysicalElementProps |
Properties that define a PhysicalElement |
|
PhysicalTypeProps |
Properties of a PhysicalType |
|
Placement2dProps |
Properties of a Placement2d |
|
Placement3dProps |
Properties of a Placement3d |
|
PropertyMetaDataProps |
|
|
RelatedElementProps |
Properties of a NavigationProperty. |
|
RelationshipProps |
Properties that are common to all types of link table ECRelationships |
|
RenderTimelineLoadProps |
Options controlling which properties are included or excluded when querying RenderTimelineProps. |
|
RenderTimelineProps |
Wire format describing a RenderTimeline. |
|
RepositoryLinkProps |
Parameters of a RepositoryLink |
|
SectionDrawingLocationProps |
Properties that define a SectionDrawingLocation |
|
SectionDrawingProps |
Properties that define a SectionDrawing. |
|
SheetBorderTemplateProps |
Properties of a SheetBorderTemplate |
|
SheetIndexEntryProps |
Properties of a SheetIndexEntry. |
|
SheetIndexReferenceProps |
Properties of a SheetIndexReference |
|
SheetProps |
Properties of a Sheet. |
|
SheetReferenceProps |
Properties of a SheetReference |
|
SheetTemplateProps |
Properties of a SheetTemplate |
|
SourceAndTarget |
Specifies the source and target elements of a Relationship instance. |
|
SubCategoryProps |
Parameters of a SubCategory |
|
SubjectProps |
Properties of a Subject |
|
SynchronizationConfigLinkProps |
The properties of a SynchronizationConfigLink |
|
TextAnnotation2dProps |
JSON representation of a TextAnnotation2d. |
|
TextAnnotation3dProps |
JSON representation of a TextAnnotation3d. |
|
TextureData |
Information about Texture data returned by queryTextureData. |
|
TextureLoadProps |
Properties that specify what texture should be loaded and how it should be loaded. |
|
TextureProps |
Properties that define a Texture element. |
|
TypeDefinitionElementProps |
Properties of a TypeDefinitionElement |
|
UrlLinkProps |
Parameters of a UrlLink |
|
ViewAttachmentLabelProps |
|
|
ViewAttachmentProps |
Properties for a ViewAttachment |
|