RelatedElement Class
The Id and relationship class of an Element that is somehow related to another Element
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: RelatedElementProps): RelatedElement | ||
toJSON(): RelatedElementProps | ||
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static | ||
idFromJson(json: any): string Static | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Properties
Name | Type | Description | |
---|---|---|---|
id Readonly | string | The Id of the element to which this element is related. | |
none Static Readonly | RelatedElement | Used to null out an existing navigation relationship. | |
relClassName Readonly | string | undefined | The full className of the relationship class. |
Defined in
- core/common/src/ElementProps.ts Line 57
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.