TypeDefinition Class

A RelatedElement relationship that describes the TypeDefinitionElement of an element.

Extends

Methods

Name Description
constructor(props: RelatedElementProps): TypeDefinition    

Inherited methods

Name Inherited from Description
toJSON(): RelatedElementProps Inherited RelatedElement  
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static Inherited RelatedElement  
idFromJson(json: any): string Static Inherited RelatedElement Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format.

Inherited properties

Name Type Inherited from Description
id Readonly Inherited string RelatedElement The Id of the element to which this element is related.
none Static Readonly Inherited RelatedElement RelatedElement Used to null out an existing navigation relationship.
relClassName Readonly Inherited string | undefined RelatedElement The full className of the relationship class.

Defined in

Last Updated: 14 November, 2024