SQLiteDb
Classes for working with SQLiteDb.
Classes
Name | Description | |
---|---|---|
SqliteChangesetReader | Read raw sqlite changeset from disk and enumerate changes. | |
SQLiteDb | A "generic" SQLiteDb. | |
VersionedSqliteDb | Abstract base class for a SQLite database that has RequiredVersionRanges stored in it. |
Interfaces
Name | Description | |
---|---|---|
ChangeFormatArgs | Format option when converting change from array to column/value object. | |
SqliteChange | Represent sqlite change. | |
SqliteChangesetReaderArgs | Arg to open a changeset file from disk |
Namespaces
Name | Description | |
---|---|---|
CloudSqlite | Types for accessing SQLite databases stored in cloud containers. | |
PropertyStore | ||
SQLiteDb |
Type Aliases
Name | Description | |
---|---|---|
AnyDb | Db from which schema will be read. | |
SqliteChangeOp | Operation that cause the change | |
SqliteValueStage | Stage is version of value that needed to be read |
Last Updated: 08 August, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.