presentation-components

Classes

Name Description
ContentDataProvider Base class for all presentation-driven content providers.
FavoritePropertiesDataFilterer IPropertyDataFilterer implementation which filters favorite properties
FavoritePropertiesDataProvider Presentation Rules-driven element favorite properties data provider implementation.
InstanceKeyValueRenderer Property value renderer for instance keys.
PresentationLabelsProvider Presentation Rules-driven labels provider implementation.
PresentationPropertyDataProvider Presentation Rules-driven property data provider implementation.
PresentationTreeDataProvider Presentation Rules-driven tree data provider. Deprecated
PropertyRecordsBuilder A Content visitor that traverses all content, creates a PropertyRecord for each property
UnifiedSelectionTreeEventHandler Tree event handler that handles unified selection. Deprecated

Constants

Name Description
DEFAULT_PROPERTY_GRID_RULESET Default presentation ruleset used by PresentationPropertyDataProvider.
NavigationPropertyEditor Editor for navigation properties. Deprecated
NavigationPropertyTargetEditor Component that renders navigation property target selector for navigation property value editing. Deprecated

Enumerations

Name Description
InfoTreeNodeItemType Type that is assigned to a PresentationInfoTreeNodeItem to determine what type of message an item conveys. Deprecated
PresentationComponentsLoggerCategory Logger categories used by this package

Global Functions

Name Description
convertToInstanceFilterDefinition Converts PresentationInstanceFilter into InstanceFilterDefinition that can be passed Deprecated
createDiagnosticsOptions Creates diagnostics options that can be passed to presentation requests based on given
createInfoNode
createInstanceFilterDefinition Creates InstanceFilterDefinition from PresentationInstanceFilterInfo.
customizeTreeNodeItem Applies customization from Node to TreeNodeItem. Deprecated
deserializeUniqueValues Function for deserializing displayValues and groupedRawValues.
isFilterablePresentationTreeNodeItem Function that check if supplied PresentationTreeNodeItem is FilterablePresentationTreeNodeItem. Deprecated
isPresentationInfoTreeNodeItem Function that checks if supplied TreeNodeItem is PresentationInfoTreeNodeItem. Deprecated
isPresentationInstanceFilterConditionGroup Function that checks if supplied PresentationInstanceFilter is PresentationInstanceFilterConditionGroup. Deprecated
isPresentationTreeNodeItem Function that checks if supplied TreeNodeItem is PresentationTreeNodeItem. Deprecated
memoize
NavigationPropertyEditorContextProvider Creates context that supplies necessary navigation property-related information for NavigationPropertyEditor.
PortalTargetContextProvider Provides a portal target for components. Deprecated
PresentationFilterBuilderValueRenderer Custom renderer of the filter rule value input.
PresentationInstanceFilterBuilder Component for building complex instance filters for filtering content and nodes produced
PresentationInstanceFilterDialog Dialog component that renders InstanceFilterBuilder inside.
PresentationTree Component that provides a convenient API for using usePresentationTreeState hook with ControlledTree. Deprecated
PresentationTreeNodeRenderer Component for rendering tree nodes produced by PresentationTreeDataProvider. Deprecated
PresentationTreeRenderer Tree renderer component that enables hierarchy level filtering in trees using PresentationTreeDataProvider. Deprecated
SchemaMetadataContextProvider Provides schema metadata to components that work with schemas.
serializeUniqueValues Function for serializing UniqueValue.
TableCellRenderer Renderer for single table cell.
UnifiedSelectionContextProvider Unified Selection context provider.
useControlledPresentationTreeFiltering A custom hook that creates filtered model source and node loader for supplied filter. Deprecated
useFilterablePresentationTree Hook that enables hierarchy level filtering with action handlers for setting and clearing filters. Deprecated
useHierarchyLevelFiltering Custom hook that creates callbacks for filtering hierarchy levels in the tree. Deprecated
useInstanceFilterPropertyInfos Custom hook that collects properties from descriptor for filter building.
useNavigationPropertyEditorContextProviderProps Custom hook that creates props for NavigationPropertyEditorContextProvider.
usePresentationTable Custom hook that loads data for generic table component.
usePresentationTableWithUnifiedSelection Custom hook that load data for generic table component.
usePresentationTreeNodeLoader Custom hooks which creates PagedTreeNodeLoader with PresentationTreeDataProvider using Deprecated
usePresentationTreeState Custom hook that creates and manages state for ControlledTree component based on presentation data. Deprecated
usePropertyDataProviderWithUnifiedSelection A React hook that adds unified selection functionality to the provided data provider.
useRulesetRegistration Custom hook which registers supplied Ruleset on mount and removes on unmount. Deprecated
useSchemaMetadataContext Returns context provided by SchemaMetadataContextProvider.
useUnifiedSelectionContext Returns Unified Selection context provided by UnifiedSelectionContextProvider.
useUnifiedSelectionTreeEventHandler A custom hook which creates and disposes UnifiedSelectionTreeEventHandler Deprecated
viewWithUnifiedSelection A HOC component that adds unified selection functionality to the supplied Deprecated

Interfaces

Name Description
CacheInvalidationProps Properties for invalidating content cache.
ContentDataProviderProps Properties for creating a ContentDataProvider instance.
ControlledPresentationTreeFilteringProps Parameters for useControlledPresentationTreeFiltering hook Deprecated
DiagnosticsProps Settings for capturing diagnostics data.
FavoritePropertiesDataFiltererProps Props for FavoritePropertiesDataFilterer.
FavoritePropertiesDataProviderProps Props for FavoritePropertiesDataProvider
FilterableTreeProps Return type of useFilterablePresentationTree hook. Deprecated
FilteringDialogToolbarHandlers Set of action handlers that are passed to toolbarButtonsRenderer for rendering custom buttons.
IContentDataProvider Interface for all presentation-driven content providers.
IFavoritePropertiesDataProvider An data provider interface for returning favorite properties for the given elements
IFilteredPresentationTreeDataProvider Filtered presentation tree data provider. Deprecated
IPresentationDataProvider Interface for a presentation data provider
IPresentationLabelsProvider Interface for presentation rules-driven labels provider.
IPresentationTreeDataProvider Presentation tree data provider. Deprecated
IUnifiedSelectionComponent An interface for all unified selection components
NavigationPropertyEditorContextProviderProps Props for NavigationPropertyEditorContextProvider.
PortalTargetContextProviderProps Props for PortalTargetContextProvider Deprecated
PresentationFilterBuilderValueRendererProps Props for PresentationFilterBuilderValueRenderer.
PresentationInfoTreeNodeItem Data structure that describes tree node item created by PresentationTreeDataProvider Deprecated
PresentationInstanceFilterBuilderProps Props for PresentationInstanceFilterBuilder component.
PresentationInstanceFilterCondition Data structure that describes single filter condition.
PresentationInstanceFilterConditionGroup Data structure that describes group of filter condition joined by logical operator.
PresentationInstanceFilterDialogProps Props for PresentationInstanceFilterDialog component.
PresentationInstanceFilterInfo Data structure that stores information about filter built by PresentationInstanceFilterDialog.
PresentationInstanceFilterPropertiesSource Data structure that describes source to gather properties from.
PresentationInstanceFilterPropertyInfo Data structure that contains information about property used for building filter.
PresentationLabelsProviderProps Properties for creating a LabelsProvider instance.
PresentationPropertyDataProviderProps Properties for creating a PresentationPropertyDataProvider instance.
PresentationTreeDataProviderDataSourceEntryPoints Definitions of methods used by PresentationTreeDataProvider to get nodes' data. Deprecated
PresentationTreeDataProviderProps Properties for creating a PresentationTreeDataProvider instance. Deprecated
PresentationTreeEventHandlerProps Props passed to eventHandlerFactory when creating event handler. Deprecated
PresentationTreeNodeItem Data structure that describes tree node item created by PresentationTreeDataProvider. Deprecated
PresentationTreeNodeItemFilteringInfo Data structure that describes information for tree item hierarchy level filtering. Deprecated
PresentationTreeNodeLoaderProps Properties for usePresentationTreeNodeLoader hook. Deprecated
PresentationTreeNodeLoaderResult Return type for usePresentationTreeNodeLoader hook. Deprecated
PresentationTreeNodeRendererProps Props for PresentationTreeNodeRenderer component. Deprecated
PresentationTreeRendererProps Props for PresentationTreeRenderer component. Deprecated
PropertyDataProviderWithUnifiedSelectionProps Props for the usePropertyDataProviderWithUnifiedSelection hook
SchemaMetadataContext Context that stores metadata related to schemas.
SchemaMetadataContextProviderProps Props for SchemaMetadataContextProvider
TableCellDefinition Data structure that defined table cell.
TableCellRendererProps Props for TableCellRenderer component.
TableColumnDefinition Data structure that defines table column.
TableRowDefinition Data structure that defined table row.
UnifiedSelectionContext Interface for accessing and modifying Unified Selection within React components.
UnifiedSelectionContextProviderProps Props for Unified Selection context provider.
UnifiedSelectionTreeEventHandlerParams Data structure that describes parameters for UnifiedSelectionTreeEventHandler Deprecated
UniqueValue
useFilterablePresentationTreeProps Props for useFilterablePresentationTree hook. Deprecated
UseHierarchyLevelFilteringProps Props for useHierarchyLevelFiltering hook. Deprecated
UseInstanceFilterPropertyInfosProps Props for useInstanceFilterPropertyInfos hook.
UsePresentationTableProps Props for usePresentationTable hook.
UsePresentationTableResult Return type of usePresentationTable hook.
UsePresentationTableWithUnifiedSelectionResult Return type of usePresentationTableWithUnifiedSelection hook.
UsePresentationTreeStateProps Properties for usePresentationTreeState hook.
UsePresentationTreeStateResult Return type of usePresentationTreeState hook.
UsePropertyDataProviderWithUnifiedSelectionResult usePropertyDataProviderWithUnifiedSelection return type.
ViewWithUnifiedSelectionProps Props that are injected to the ViewWithUnifiedSelection HOC component. Deprecated

Namespaces

Name Description
CacheInvalidationProps
PresentationInstanceFilter

Type Aliases

Name Description
FilterablePresentationTreeNodeItem Describes tree node item that supports hierarchy level filtering. Deprecated
HierarchyLevelFilteringDescriptor Describes descriptor used for hierarchy level filtering. Deprecated
IPresentationPropertyDataProvider Interface for presentation rules-driven property data provider.
PresentationInstanceFilter Type that describes instance filter based on Descriptor fields.
PresentationTreeProps Props for PresentationTree component.
UnifiedSelectionState Describes how to access the current Unified Selection state.

Last Updated: 17 December, 2024