ContentDataProvider Class
Base class for all presentation-driven content providers.
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: ContentDataProviderProps): ContentDataProvider | Constructor. | |
dispose(): void | Destructor. | |
getContent(pageOptions?: PageOptions): Promise<undefined | Content> | Get the content. | |
getContentSetSize(): Promise<number> | Get the number of content records. | |
getDescriptorOverrides(): Promise<DescriptorOverrides> Protected | Get the content descriptor overrides. | |
getFieldByPropertyDescription(descr: PropertyDescription): Promise<undefined | Field> | Get field that was used to create a property record with given property description. | |
getFieldByPropertyRecord(propertyRecord: PropertyRecord): Promise<undefined | Field> | Get field using PropertyRecord. | Deprecated |
invalidateCache(props: CacheInvalidationProps): void Protected | Invalidates cached content. | |
shouldRequestContentForEmptyKeyset(): boolean Protected | Called to check if content should be requested even when keys is empty. |
Properties
Name | Type | Description | |
---|---|---|---|
displayType Accessor ReadOnly | string | Display type used to format content | |
getContentDescriptor | Memoized<() => Promise<undefined | Descriptor>> | Get the content descriptor. | |
imodel Accessor | IModelConnection | IModel to pull data from | |
keys Accessor | KeySet | Keys defining what to request content for | |
pagingSize Accessor | undefined | number | Paging options for obtaining content. | |
rulesetId Accessor | string | Id of the ruleset to use when requesting content | |
selectionInfo Accessor | undefined | SelectionInfo | Information about selection event that results in content change |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.