DescriptorOverrides Interface
Descriptor overrides that can be used to customize content
Properties
Name | Type | Description | |
---|---|---|---|
contentFlags | number | undefined | Content flags used for content customization. | |
displayType | string | undefined | Content display type. | |
fieldsFilterExpression | string | undefined | ECExpression for filtering content by | |
fieldsSelector | { fields: FieldDescriptor[], type: "include" | "exclude" } | undefined | Fields selector that allows excluding or including only specified fields. | |
filterExpression | string | undefined | ECExpression for filtering content | Deprecated |
instanceFilter | InstanceFilterDefinition | undefined | Instances filter that allows filtering content by class, properties of specific class | |
sorting | { direction: SortDirection, field: FieldDescriptor } | undefined | Specification for sorting data. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.