Name |
Description |
|
ArrayPropertiesFieldJSON |
Data structure for a ArrayPropertiesField serialized to JSON. |
|
ArrayTypeDescription |
Type description for array properties. |
|
BaseFieldJSON |
Data structure for a Field serialized to JSON. |
|
BaseTypeDescription |
Data structure for base content field type description. |
|
CategoryDescription |
A data structure that describes a Field category. |
|
CategoryDescriptionJSON |
Serialized CategoryDescription JSON representation. |
|
ContentJSON |
Serialized Content JSON representation. |
|
DescriptorJSON |
Serialized Descriptor JSON representation. |
|
DescriptorOverrides |
Descriptor overrides that can be used to customize content |
|
DescriptorSource |
Descriptor properties |
|
DisplayValueGroup |
A group of raw values and their common display value. |
|
DisplayValueGroupJSON |
JSON representation of DisplayValueGroup. |
Deprecated |
DisplayValuesArray |
An array of display values |
|
DisplayValuesArrayJSON |
JSON representation of DisplayValuesArray |
Deprecated |
DisplayValuesMap |
A map of display values |
|
DisplayValuesMapJSON |
JSON representation of DisplayValuesMap |
Deprecated |
EditorDescription |
A data structure which describes property editor used |
|
FieldDescriptorBase |
Base for a field descriptor |
|
FieldHierarchy |
A data structure to define a hierarchy of Field objects. |
|
IContentVisitor |
An interface for a visitor that can be passed to the traverseContent function |
|
ItemJSON |
Serialized Item JSON representation. |
|
NamedFieldDescriptor |
Field descriptor that identifies a content field by its unique name. |
|
NavigationPropertyValue |
Data structure that describes value of the navigation property. |
|
NestedContentFieldJSON |
Data structure for a NestedContentField serialized to JSON. |
|
NestedContentValue |
Data structure that describes nested content value. |
|
NestedContentValueJSON |
JSON representation of NestedContentValue |
Deprecated |
PrimitiveTypeDescription |
Type description for primitive properties. |
|
ProcessFieldHierarchiesProps |
Props for the processFieldHierarchies call. |
|
ProcessMergedValueProps |
Props for the processMergedValue call. |
|
ProcessPrimitiveValueProps |
Props for the processPrimitiveValue call. |
|
PropertiesFieldDescriptor |
Field descriptor that identifies a properties field using a list of |
|
PropertiesFieldJSON |
Data structure for a PropertiesField serialized to JSON. |
|
Property |
Data structure that describes a single ECProperty that's |
|
PropertyAccessor |
Data structure that describes one step of property |
|
PropertyJSON |
JSON representation of Property |
|
RendererDescription |
Describes property renderer used for a content Field. |
|
SelectClassInfo |
Data structure that describes an ECClass in content Descriptor. |
|
SelectClassInfoJSON |
Serialized SelectClassInfo JSON representation |
|
SelectionInfo |
Data structure that contains selection information. |
|
StartArrayProps |
Props for the startArray call. |
|
StartCategoryProps |
Props for the startCategory call. |
|
StartContentProps |
Props for the startContent call. |
|
StartFieldProps |
Props for the startField call. |
|
StartItemProps |
Props for the startItem call. |
|
StartStructProps |
Props for the startStruct call. |
|
StructFieldMemberDescription |
A data structure that describes a struct member. |
|
StructPropertiesFieldJSON |
Data structure for a StructPropertiesField serialized to JSON. |
|
StructTypeDescription |
Type description for struct properties. |
|
ValuesArray |
An array of raw values |
|
ValuesArrayJSON |
JSON representation of ValuesArray |
Deprecated |
ValuesMap |
A map of raw values |
|
ValuesMapJSON |
JSON representation of ValuesMap |
Deprecated |