PropertiesField Class
Describes a content field that's based on one or more similar
EC properties.
Extends
Extended by
Methods
Name |
Description |
|
constructor(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, properties: Property[], editor?: EditorDescription, renderer?: RendererDescription): PropertiesField |
Creates an instance of PropertiesField. |
|
clone(): PropertiesField |
|
|
getFieldDescriptor(): FieldDescriptor |
Get descriptor for this field. |
|
isArrayPropertiesField(): this is ArrayPropertiesField |
Is this a an array property field |
|
isStructPropertiesField(): this is StructPropertiesField |
Is this a an struct property field |
|
matchesDescriptor(descriptor: FieldDescriptor): boolean |
Checks if this field matches given field descriptor |
|
toCompressedJSON(classesMap: { T }): PropertiesFieldJSON<string> |
Serialize this object to compressed JSON |
|
toJSON(): PropertiesFieldJSON<ClassInfoJSON> |
Serialize this object to JSON |
|
fromCompressedJSON(json: PropertiesFieldJSON<string>, classesMap: { T }, categories: CategoryDescription[]): undefined | PropertiesField Static |
Deserialize a PropertiesField from compressed JSON. |
|
fromJSON(json: PropertiesFieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | PropertiesField Static |
Deserialize PropertiesField from JSON |
|
Inherited methods
Properties
Name |
Type |
Description |
|
properties |
Property[] |
A list of properties this field is created from |
|
Inherited properties
Defined in
Last Updated: 14 November, 2024