CategoryDescription Namespace
Function
Name | Description |
---|---|
CategoryDescription.fromJSON | Deserialize CategoryDescription from JSON. |
CategoryDescription.listFromJSON | Deserialize a list of CategoryDescription from JSON. |
CategoryDescription.toJSON | Serialize given category to JSON |
Defined in
CategoryDescription Interface
A data structure that describes a Field category.
Properties
Name | Type | Description | |
---|---|---|---|
description | string | Extensive description | |
expand | boolean | Should this category be auto-expanded when it's displayed in the UI | |
label | string | Display label | |
name | string | Unique name | |
parent | CategoryDescription | undefined | Parent category description | |
priority | number | Priority. | |
renderer | RendererDescription | undefined | Custom renderer description |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.