NestedContentField Class
Describes a content field that contains Nested content.
Extends
Methods
Name | Description | |
---|---|---|
constructor(category: CategoryDescription, name: string, label: string, description: TypeDescription, isReadonly: boolean, priority: number, contentClassInfo: ClassInfo, pathToPrimaryClass: RelationshipPath, nestedFields: Field[], editor?: EditorDescription, autoExpand?: boolean, renderer?: RendererDescription): NestedContentField | Creates an instance of NestedContentField. | |
clone(): NestedContentField | ||
getFieldByName(name: string, recurse?: boolean): undefined | Field | Get field by its name | |
rebuildParentship(parentField?: NestedContentField): void | Sets provided NestedContentField as parent of this fields and recursively updates | |
resetParentship(): void | Resets parent of this field and all nested fields. | |
toCompressedJSON(classesMap: { T }): NestedContentFieldJSON<string> | Serialize this object to compressed JSON | |
toJSON(): NestedContentFieldJSON<ClassInfoJSON> | Serialize this object to JSON | |
fromCompressedJSON(json: NestedContentFieldJSON<string>, classesMap: { T }, categories: CategoryDescription[]): any Static | Deserialize a NestedContentField from compressed JSON. | |
fromJSON(json: NestedContentFieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): undefined | NestedContentField Static | Deserialize NestedContentField from JSON | Deprecated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getFieldDescriptor(): FieldDescriptor Inherited | Field | Get descriptor for this field. |
isNestedContentField(): this is NestedContentField Inherited | Field | Is this a NestedContentField |
isPropertiesField(): this is PropertiesField Inherited | Field | Is this a PropertiesField |
matchesDescriptor(descriptor: FieldDescriptor): boolean Inherited | Field | Checks if this field matches given field descriptor |
getCategoryFromFieldJson(fieldJson: FieldJSON<ClassInfoJSON>, categories: CategoryDescription[]): CategoryDescription Protected Static Inherited | Field |
Properties
Name | Type | Description | |
---|---|---|---|
actualPrimaryClassIds | string[] | When content descriptor is requested in a polymorphic fashion, fields get created if at least one of the concrete classes | |
autoExpand | boolean | undefined | Flag specifying whether field should be expanded | |
contentClassInfo | ClassInfo | Information about an ECClass whose properties are nested inside this field | |
nestedFields | Field[] | Contained nested fields | |
pathToPrimaryClass | RelationshipPath | Relationship path to Primary class | |
relationshipMeaning | RelationshipMeaning | Meaning of the relationship between the primary class |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category Inherited | CategoryDescription | Field | Category information |
editor Inherited | EditorDescription | undefined | Field | Property editor used to edit values of this field |
extendedData Inherited | { T } | undefined | Field | Extended data associated with this field |
isReadonly Inherited | boolean | Field | Are values in this field read-only |
label Inherited | string | Field | Display label |
name Inherited | string | Field | Unique name |
parent Accessor Inherited ReadOnly | undefined | NestedContentField | Field | Get parent |
priority Inherited | number | Field | Priority of the field. |
renderer Inherited | RendererDescription | undefined | Field | Property renderer used to render values of this field |
type Inherited | TypeDescription | Field | Description of this field's values data type |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.