PropertiesFieldJSON<TClassInfoJSON> Interface

Data structure for a PropertiesField serialized to JSON.

Extends

Properties

Name Type Description
properties PropertyJSON<TClassInfoJSON>[]    

Inherited properties

Name Type Inherited from Description
category Inherited string BaseFieldJSON  
editor Inherited EditorDescription | undefined BaseFieldJSON  
extendedData Inherited { T } | undefined BaseFieldJSON  
isReadonly Inherited boolean BaseFieldJSON  
label Inherited string BaseFieldJSON  
name Inherited string BaseFieldJSON  
priority Inherited number BaseFieldJSON  
renderer Inherited RendererDescription | undefined BaseFieldJSON  
type Inherited TypeDescription BaseFieldJSON  

Defined in

Last Updated: 14 November, 2024