Item Class
A data structure that represents a single content record.
Methods
Name | Description | |
---|---|---|
constructor(primaryKeys: InstanceKey[], label: string | LabelDefinition, imageId: string, classInfo: ClassInfo, values: ValuesDictionary<Value>, displayValues: ValuesDictionary<DisplayValue>, mergedFieldNames: string[], extendedData?: { T }): Item | Creates an instance of Item. | |
isFieldMerged(fieldName: string): boolean | Is value of field with the specified name merged in this record. | |
toJSON(): ItemJSON | Serialize this object to JSON | |
fromJSON(json: string | ItemJSON): undefined | Item Static | Deserialize Item from JSON |
Properties
Name | Type | Description | |
---|---|---|---|
classInfo | ClassInfo | undefined | For cases when item consists only of same class instances, information about the ECClass | |
displayValues | ValuesDictionary<DisplayValue> | Display values dictionary | |
extendedData | { T } | undefined | Extended data injected into this content item | |
imageId | string | ID of the image associated with this item | Deprecated |
inputKeys | InstanceKey[] | undefined | Keys of input instances that caused this item to be included in content. | |
label | LabelDefinition | Display label of the item | |
mergedFieldNames | string[] | List of field names whose values are merged (see Merging values) | |
primaryKeys | InstanceKey[] | Keys of instances whose data is contained in this item | |
values | ValuesDictionary<Value> | Raw values dictionary |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.