NestedContentValue Namespace
Function
Name | Description |
---|---|
NestedContentValue.fromJSON | Deserialize NestedContentValue from JSON |
NestedContentValue.toJSON | Serialize NestedContentValue to JSON |
Defined in
NestedContentValue Interface
Data structure that describes nested content value.
Properties
Name | Type | Description | |
---|---|---|---|
displayValues | ValuesDictionary<DisplayValue> | Content display values map | |
labelDefinition | LabelDefinition | undefined | Label of the ECInstance that this NestedContentValue is based on. |
|
mergedFieldNames | string[] | Names of fields whose values are merged | |
primaryKeys | InstanceKey[] | Keys of instances whose content is contained in this value | |
values | ValuesDictionary<Value> | Content values map |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.