SelectClassInfo Namespace
Function
Name | Description |
---|---|
SelectClassInfo.fromCompressedJSON | Deserialize SelectClassInfo from compressed JSON |
SelectClassInfo.toCompressedJSON | Serialize SelectClassInfo to compressed JSON |
Defined in
SelectClassInfo Interface
Data structure that describes an ECClass in content Descriptor.
Properties
Name | Type | Description | |
---|---|---|---|
isSelectPolymorphic | boolean | Is the class handled polymorphically | |
navigationPropertyClasses | RelatedClassInfo[] | undefined | Relationship paths to navigation property classes | |
pathFromInputToSelectClass | RelatedClassInfoWithOptionalRelationship[] | undefined | Relationship path from input class to the select class. | |
relatedInstancePaths | RelationshipPath[] | undefined | Relationship paths to related instance classes. | |
relatedPropertyPaths | RelationshipPath[] | undefined | Relationship paths to related property classes | |
selectClassInfo | ClassInfo | Information about the ECClass |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.