RelatedClassInfo Namespace
Function
Name | Description |
---|---|
RelatedClassInfo.equals | Check two RelatedClassInfo or StrippedRelatedClassInfo for equality |
RelatedClassInfo.fromCompressedJSON | Deserialize RelatedClassInfo from compressed JSON |
RelatedClassInfo.fromJSON | Deserialize RelatedClassInfo from JSON |
RelatedClassInfo.strip | Strip given RelatedClassInfo to StrippedRelatedClassInfo |
RelatedClassInfo.toCompressedJSON | Serialize RelatedClassInfo to compressed JSON |
RelatedClassInfo.toJSON | Serialize RelatedClassInfo to JSON |
Defined in
RelatedClassInfo Interface
A structure that describes a related class and the properties of that relationship.
Properties
Name | Type | Description | |
---|---|---|---|
isForwardRelationship | boolean | Should relationship be followed in a forward direction to access the related class. | |
isPolymorphicRelationship | boolean | undefined | Is relationship handled polymorphically | |
isPolymorphicTargetClass | boolean | undefined | Is target class handled polymorphically | |
relationshipInfo | ClassInfo | Information about the ECRelationship | |
sourceClassInfo | ClassInfo | Information about the source ECClass | |
targetClassInfo | ClassInfo | Information about the target ECClass | |
targetInstanceIds | string[] | undefined | Optionally, IDs of specific target class instances. |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.