Descriptor Class
Data structure that describes content: fields, sorting, filtering, format, etc. Descriptor may be changed to control how content is created.
Implements
Methods
Name | Description | |
---|---|---|
constructor(source: DescriptorSource): Descriptor | Construct a new Descriptor using a DescriptorSource | |
createDescriptorOverrides(): DescriptorOverrides | Create descriptor overrides object from this descriptor. | |
getFieldByDescriptor(fieldDescriptor: FieldDescriptor, recurse?: boolean): undefined | Field | Get field by its descriptor. | |
getFieldByName(name: string, recurse?: boolean): undefined | Field | Get field by its name | |
toJSON(): DescriptorJSON | Serialize Descriptor to JSON | |
fromJSON(json: DescriptorJSON): undefined | Descriptor Static | Deserialize Descriptor from JSON |
Properties
Name | Type | Description | |
---|---|---|---|
categories Readonly | CategoryDescription[] | A list of content field categories used in this descriptor | |
connectionId Readonly | string | undefined | Id of the connection used to create the descriptor | |
contentFlags Readonly | number | ContentFlags used to create the descriptor | |
contentOptions Readonly | any | Extended options used to create the descriptor. | Deprecated |
displayType Readonly | string | Display type used to create the descriptor | |
fields Readonly | Field[] | A list of fields contained in the descriptor | |
fieldsFilterExpression | string | undefined | ECExpression for filtering content by | |
filterExpression | string | undefined | ECExpression for filtering content | Deprecated |
inputKeysHash Readonly | string | undefined | Hash of the input keys used to create the descriptor | |
instanceFilter | InstanceFilterDefinition | undefined | Instances filter that allows filtering content by class, properties of specific class | |
ruleset Readonly | Ruleset | undefined | A ruleset used to create this descriptor. | |
selectClasses Readonly | SelectClassInfo[] | A list of classes that will be selected when creating content with this descriptor | |
selectionInfo Readonly | SelectionInfo | undefined | Selection info used to create the descriptor | |
sortDirection | SortDirection | undefined | Sorting direction | |
sortingField | Field | undefined | Field used to sort the content |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.