DescriptorJSON Interface
Serialized Descriptor JSON representation.
Properties
Name | Type | Description | |
---|---|---|---|
categories | CategoryDescriptionJSON[] | ||
classesMap | { T } | ||
connectionId | string | ||
contentFlags | number | ||
contentOptions | any | Deprecated | |
displayType | string | ||
fields | FieldJSON<string>[] | ||
fieldsFilterExpression | string | undefined | ||
filterExpression | string | undefined | Deprecated | |
inputKeysHash | string | ||
instanceFilter | InstanceFilterDefinition | undefined | ||
ruleset | Ruleset | undefined | ||
selectClasses | SelectClassInfoJSON<string>[] | ||
selectionInfo | SelectionInfo | undefined | ||
sortDirection | SortDirection | undefined | ||
sortingFieldName | string | undefined |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.