PresentationPropertyDataProvider Class
Presentation Rules-driven property data provider implementation.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: PresentationPropertyDataProviderProps): PresentationPropertyDataProvider | Constructor | |
dispose(): void | Dispose the presentation property data provider. | |
getData(): Promise<PropertyData> | Returns property data. | |
getDescriptorOverrides(): Promise<DescriptorOverrides> Protected | Provides content configuration for the property grid | |
getPropertyRecordInstanceKeys(record: PropertyRecord): Promise<InstanceKey[]> | Get keys of instances which were used to create given PropertyRecord. | |
invalidateCache(props: CacheInvalidationProps): void Protected | Invalidates cached content and clears categorized data. | |
isFieldFavorite(field: Field): boolean Protected | Should the specified field be included in the favorites category. | Deprecated |
isFieldFavoriteAsync(field: Field): Promise<boolean> Protected | Should the specified field be included in the favorites category. | |
isFieldHidden(field: Field): boolean Protected | Hides the computed display label field from the list of properties | |
sortCategories(categories: CategoryDescription[]): void Protected | Sorts the specified list of categories by priority. | |
sortFields(category: CategoryDescription, fields: Field[]): void Protected | Sorts the specified list of fields by priority. | Deprecated |
sortFieldsAsync(category: CategoryDescription, fields: Field[]): Promise<void> Protected | Sorts the specified list of fields by priority. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getContent(pageOptions?: PageOptions): Promise<undefined | Content> | ContentDataProvider | Get the content. |
getContentSetSize(): Promise<number> | ContentDataProvider | Get the number of content records. |
getFieldByPropertyDescription(descr: PropertyDescription): Promise<undefined | Field> | ContentDataProvider | Get field that was used to create a property record with given property description. |
getFieldByPropertyRecord(propertyRecord: PropertyRecord): Promise<undefined | Field> | ContentDataProvider | Get field using PropertyRecord. |
shouldRequestContentForEmptyKeyset(): boolean Protected | ContentDataProvider | Called to check if content should be requested even when keys is empty. |
Properties
Name | Type | Description | |
---|---|---|---|
getMemoizedData Protected | Memoized<() => Promise<PropertyData>> | Returns property data. | |
includeFieldsWithCompositeValues Accessor | boolean | Should fields with composite values be included in the property list. | |
includeFieldsWithNoValues Accessor | boolean | Should fields with no values be included in the property list. | |
isNestedPropertyCategoryGroupingEnabled Accessor | boolean | Is nested property categories enabled. | |
onDataChanged | PropertyDataChangeEvent |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayType Accessor ReadOnly | string | ContentDataProvider | Display type used to format content |
getContentDescriptor | Memoized<() => Promise<undefined | Descriptor>> | ContentDataProvider | Get the content descriptor. |
imodel Accessor | IModelConnection | ContentDataProvider | IModel to pull data from |
keys Accessor | KeySet | ContentDataProvider | Keys defining what to request content for |
pagingSize Accessor | undefined | number | ContentDataProvider | Paging options for obtaining content. |
rulesetId Accessor | string | ContentDataProvider | Id of the ruleset to use when requesting content |
selectionInfo Accessor | undefined | SelectionInfo | ContentDataProvider | Information about selection event that results in content change |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.