ContentDataProviderProps Interface
Properties for creating a ContentDataProvider
instance.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
displayType | string | The content display type which this provider is going to load data for. | |
imodel | IModelConnection | IModel to pull data from. | |
pagingSize | number | undefined | Paging size for obtaining content records. | |
ruleset | string | Ruleset | Id of the ruleset to use when requesting content or a ruleset itself. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
devDiagnostics | { backendVersion?: boolean, handler: ClientDiagnosticsHandler, perf?: boolean | { minimumDuration: number }, severity?: DiagnosticsLoggerSeverity } | undefined | DiagnosticsProps | Settings for capturing rules engine diagnostics. |
ruleDiagnostics | { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | undefined | DiagnosticsProps | Settings for capturing rule diagnostics. |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.