IContentDataProvider Interface
Interface for all presentation-driven content providers.
Extends
Implemented by
Properties
Name | Type | Description | |
---|---|---|---|
displayType Readonly | string | Display type used to format content | |
getContent | (pageOptions?: PageOptions) => Promise<undefined | Content> | Get the content. | |
getContentDescriptor | () => Promise<undefined | Descriptor> | Get the content descriptor. | |
getContentSetSize | () => Promise<number> | Get the number of content records. | |
getFieldByPropertyDescription | (descr: PropertyDescription) => Promise<undefined | Field> | Get field that was used to create a property record with given property description. | |
getFieldByPropertyRecord | (propertyRecord: PropertyRecord) => Promise<undefined | Field> | Get field that was used to create the given property record. | Deprecated |
keys | KeySet | Keys defining what to request content for | |
selectionInfo | undefined | SelectionInfo | Information about selection event that results in content change |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
imodel Readonly | IModelConnection | IPresentationDataProvider | IModelConnection used by this data provider |
rulesetId Readonly | string | IPresentationDataProvider | Id of the ruleset used by this data provider |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.