UsePresentationTableResult<TColumns, TRow> Interface
Return type of usePresentationTable hook.
Properties
Name | Type | Description | |
---|---|---|---|
columns | undefined | TColumns[] | List of table columns. | |
filter | (filterExpression?: string) => void | Filters table data using provided ECExpression. | |
isLoading | boolean | Specifies whether rows loading is on going. | |
loadMoreRows | () => void | Loads more rows if there are any available. | |
rows | TRow[] | List of table rows loaded. | |
sort | (columnName?: string, descending?: boolean) => void | Sorts table data by the specific column. |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.