PresentationFilterBuilderValueRenderer Function
Custom renderer of the filter rule value input. It extends default value input functionality:
- For
IsEqual
andIsNotEqual
operators it renders a selector with unique property values. Unique values are collected from the instances described by the descriptor (descriptor and descriptorInputKeys). - For kind of quantity properties it renders input with units support.
PresentationFilterBuilderValueRenderer(__namedParameters: PresentationFilterBuilderValueRendererProps): JSX.Element
Parameter | Type | Description |
---|---|---|
__namedParameters | PresentationFilterBuilderValueRendererProps |
Returns - JSX.Element
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.