InstanceKeyValueRenderer Class
Property value renderer for instance keys. If application provides a UnifiedSelectionContext and this value is clicked, the current selection is replaced with the instance pointed by the key. The selection changes at the default selection level as provided by the context.
Implements
Methods
Name | Description | |
---|---|---|
constructor(): InstanceKeyValueRenderer | ||
canRender(record: PropertyRecord): boolean | Checks if the renderer can handle given property | |
render(record: PropertyRecord, context?: PropertyValueRendererContext): JSX.Element | Method that returns a JSX representation of PropertyRecord |
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.