UnifiedSelectionContext Interface
Interface for accessing and modifying Unified Selection within React components.
Methods
Name | Description | |
---|---|---|
addToSelection(keys: Keys, level?: number): void | Adds keys to current selection. | |
clearSelection(level?: number): void | Removes all keys from current selection. | |
removeFromSelection(keys: Keys, level?: number): void | Removes keys from current selection. | |
replaceSelection(keys: Keys, level?: number): void | Removes all keys from current selection and selects only the specified keys. |
Properties
Name | Type | Description | |
---|---|---|---|
getSelection | UnifiedSelectionState | Returns current selection. | |
imodel | IModelConnection | iModel associated with the selection. | |
selectionLevel | number | Default selection level. |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.