PropertyValueRendererContext Interface
Additional parameters to the renderer
Properties
Name | Type | Description | |
---|---|---|---|
containerType | string | undefined | Type of container that holds the property | |
defaultValue | React.ReactNode | undefined | Default value to show if value rendering is asynchronous | |
isExpanded | boolean | undefined | Whether property value is expanded. | |
onDialogOpen | (dialogState: PropertyDialogState) => void | undefined | Callback to request for Dialog to be opened. | |
onExpansionToggled | () => void | undefined | Called when property value expansion or collapse is requested. | |
onHeightChanged | (newHeight: number) => void | undefined | Called when property value element height changes. | |
onPopupHide | () => void | undefined | Callback to request for a Popup to be hidden. | |
onPopupShow | (popupState: PropertyPopupState) => void | undefined | Callback to request for a Popup to be shown. | |
orientation | Orientation | undefined | Orientation of property/container | |
style | React.CSSProperties | undefined | Style that should be applied to the rendered element | |
textHighlighter | (text: string) => React.ReactNode | undefined | Callback to highlight text |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.