UsePresentationTableWithUnifiedSelectionResult<TColumns, TRow> Interface

Return type of usePresentationTableWithUnifiedSelection hook.

Extends

Properties

Name Type Description
onSelect (selectedRowKeys: string[]) => void A function that should be called when a table row is selected.  
selectedRows TRow[] Specifies rows that have been selected (toggled) by other components on the appropriate selection level.  

Inherited properties

Name Type Inherited from Description
columns Inherited undefined | TColumns[] UsePresentationTableResult<TColumns, TRow> List of table columns.
filter Inherited (filterExpression?: string) => void UsePresentationTableResult<TColumns, TRow> Filters table data using provided ECExpression.
isLoading Inherited boolean UsePresentationTableResult<TColumns, TRow> Specifies whether rows loading is on going.
loadMoreRows Inherited () => void UsePresentationTableResult<TColumns, TRow> Loads more rows if there are any available.
rows Inherited TRow[] UsePresentationTableResult<TColumns, TRow> List of table rows loaded.
sort Inherited (columnName?: string, descending?: boolean) => void UsePresentationTableResult<TColumns, TRow> Sorts table data by the specific column.

Defined in

Last Updated: 17 December, 2024