usePresentationTableWithUnifiedSelection Function
Custom hook that load data for generic table component. It uses Unified Selection to get keys defining what to load rows for.
usePresentationTableWithUnifiedSelection<TColumn, TRow>(props: Omit<UsePresentationTableProps<TColumn, TRow>, "keys">): UsePresentationTableWithUnifiedSelectionResult<TColumn, TRow>
@throws on failure to get table data. The error is thrown in the React's render loop, so it can be caught using an error boundary.
Parameter | Type | Description |
---|---|---|
props | Omit<UsePresentationTableProps<TColumn, TRow>, "keys"> |
Returns - UsePresentationTableWithUnifiedSelectionResult<TColumn, TRow>
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.