useHierarchyLevelFiltering Function
Deprecated in 5.7. All tree-related APIs have been deprecated in favor of the new generation hierarchy
building APIs (see https://github.com/iTwin/presentation/blob/33e79ee8d77f30580a9bab81a72884bda008db25/README.md#the-packages).
Custom hook that creates callbacks for filtering hierarchy levels in the tree. Filtering works only with trees based on PresentationTreeDataProvider.
useHierarchyLevelFiltering(props: UseHierarchyLevelFilteringProps): { applyFilter: (nodeId: string, info: PresentationInstanceFilterInfo) => void, clearFilter: (nodeId: string) => void }
Parameter | Type | Description |
---|---|---|
props | UseHierarchyLevelFilteringProps |
Returns - { applyFilter: (nodeId: string, info: PresentationInstanceFilterInfo) => void, clearFilter: (nodeId: string) => void }
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.