PropertyRecordsBuilder Class
A Content
visitor that traverses all content, creates a PropertyRecord
for each property
and streams them into the given callback function.
Implements
Methods
Name | Description | |
---|---|---|
constructor(visitPropertyRecord: (record: PropertyRecord) => void): PropertyRecordsBuilder | ||
finishArray(): void | Called after processing of array value is complete. | |
finishCategory(): void | Called after processing of field is complete for every category in the field's category stack. | |
finishContent(): void | Called after processing of Content is complete. | |
finishField(): void | Called after processing of Field for individual Item is complete. | |
finishItem(): void | Called after processing of Item is complete. | |
finishStruct(): void | Called after processing of struct value is complete. | |
processFieldHierarchies(props: ProcessFieldHierarchiesProps): void | Called to post-process field hierarchies after they're extracted from Descriptor in processed Content. | |
processMergedValue(props: ProcessMergedValueProps): void | Called to process a merged value. | |
processPrimitiveValue(props: ProcessPrimitiveValueProps): void | Called to process a primitive value. | |
startArray(props: StartArrayProps): boolean | Called before processing an array value. | |
startCategory(props: StartCategoryProps): boolean | Called before processing a content item field (startField call) for each category in the field's | |
startContent(props: StartContentProps): boolean | Called before starting Content processing. | |
startField(props: StartFieldProps): boolean | Called before starting Field processing for each individual Item. | |
startItem(props: StartItemProps): boolean | Called before starting each Item processing. | |
startStruct(props: StartStructProps): boolean | Called before processing a struct value. |
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.