IFilteredPresentationTreeDataProvider Interface
Deprecated in 5.7. All tree-related APIs have been deprecated in favor of the new generation hierarchy
building APIs (see https://github.com/iTwin/presentation/blob/33e79ee8d77f30580a9bab81a72884bda008db25/README.md#the-packages).
Filtered presentation tree data provider.
Extends
Methods
Name | Description | |
---|---|---|
countFilteringResults(nodePaths: ReadonlyArray<Readonly<NodePathElement>>): number | Counts all filter matches. | |
getActiveMatch(index: number): undefined | ActiveMatchInfo | Returns active match for given index. | |
nodeMatchesFilter(node: TreeNodeItem): boolean | Checks whether node matches applied filter or not. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
createRequestOptions(parentKey?: NodeKey, instanceFilter?: InstanceFilterDefinition): HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> Inherited | IPresentationTreeDataProvider | Creates options for nodes request. |
dispose(): void Inherited | IPresentationTreeDataProvider | Disposes the provider. |
getFilteredNodePaths(filter: string): Promise<NodePathElement[]> Inherited | IPresentationTreeDataProvider | Returns filtered node paths. |
getNodeKey(node: TreeNodeItem): NodeKey Inherited | IPresentationTreeDataProvider | Returns a NodeKey from given TreeNodeItem. |
Properties
Name | Type | Description | |
---|---|---|---|
filter | string | Applied filter. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
[dispose] Inherited | () => void | undefined | IPresentationTreeDataProvider | Disposes the provider. |
imodel Readonly Inherited | IModelConnection | IPresentationTreeDataProvider | IModelConnection used by this data provider |
rulesetId Readonly Inherited | string | IPresentationTreeDataProvider | Id of the ruleset used by this data provider |
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.