NodePathElement Namespace
Function
Name | Description |
---|---|
NodePathElement.fromJSON | Deserialize NodePathElement from JSON |
NodePathElement.toJSON | Serialize given NodePathElement to JSON |
Defined in
NodePathElement Interface
Describes a single step in the nodes path.
Properties
Name | Type | Description | |
---|---|---|---|
children | NodePathElement[] | Child path elements | |
filteringData | NodePathFilteringData | undefined | Additional filtering-related information | |
index | number | Node index | |
isMarked | boolean | undefined | Is this element part of the marked path | |
node | Node | Node instance |
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.