TreeNodeItem Interface
A node item which can be displayed in a tree.
Properties
Name | Type | Description | |
---|---|---|---|
autoExpand | boolean | undefined | ||
checkBoxState | CheckBoxState | undefined | ||
description | string | undefined | ||
extendedData | [key: string]: any | undefined | A key-value pairs data structure that can be used by data provider | |
icon | string | undefined | ||
id | string | ||
isCheckboxDisabled | boolean | undefined | ||
isCheckboxVisible | boolean | undefined | ||
isEditable | boolean | undefined | ||
isSelectionDisabled | boolean | undefined | ||
label | PropertyRecord | ||
parentId | string | undefined | ||
style | ItemStyle | undefined |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.