IPresentationTreeDataProvider Interface
Deprecated in 5.7. All tree-related APIs have been deprecated in favor of the new generation hierarchy
building APIs (see https://github.com/iTwin/presentation/blob/33e79ee8d77f30580a9bab81a72884bda008db25/README.md#the-packages).
Presentation tree data provider.
Extends
Implemented by
Methods
Name | Description | |
---|---|---|
createRequestOptions(parentKey?: NodeKey, instanceFilter?: InstanceFilterDefinition): HierarchyRequestOptions<IModelConnection, NodeKey, RulesetVariable> | Creates options for nodes request. | |
getFilteredNodePaths(filter: string): Promise<NodePathElement[]> | Returns filtered node paths. | |
getNodeKey(node: TreeNodeItem): NodeKey | Returns a NodeKey from given TreeNodeItem. | Deprecated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
dispose(): void Inherited | IPresentationDataProvider | Disposes the provider. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
[dispose] Inherited | () => void | undefined | IPresentationDataProvider | Disposes the provider. |
imodel Readonly Inherited | IModelConnection | IPresentationDataProvider | IModelConnection used by this data provider |
rulesetId Readonly Inherited | string | IPresentationDataProvider | Id of the ruleset used by this data provider |
Defined in
Last Updated: 17 December, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.