PresentationTreeNodeLoaderProps Interface

Deprecated  in 4.x. This hook is not compatible with React 18 StrictMode. Use usePresentationTreeState instead.

Properties for usePresentationTreeNodeLoader hook.

Extends

Properties

Name Type Description
pagingSize number Number of nodes in a single page.  
seedTreeModel TreeModel | undefined Initialize tree data with the provided tree model.  

Inherited properties

Name Type Inherited from Description
appendChildrenCountForGroupingNodes Inherited boolean | undefined PresentationTreeDataProviderProps Should grouping nodes have a suffix with grouped nodes count.
customizeTreeNodeItem Inherited (item: Partial<DelayLoadedTreeNodeItem>, node: Partial<Node>) => void | undefined PresentationTreeDataProviderProps Callback which provides a way to customize how data is mapped between Node and TreeNodeItem.
dataSourceOverrides Inherited Partial<PresentationTreeDataProviderDataSourceEntryPoints> | undefined PresentationTreeDataProviderProps By default the provider uses PresentationManager accessed through Presentation.presentation to request
devDiagnostics Inherited { backendVersion?: boolean, handler: ClientDiagnosticsHandler, perf?: boolean | { minimumDuration: number }, severity?: DiagnosticsLoggerSeverity } | undefined PresentationTreeDataProviderProps Settings for capturing rules engine diagnostics.
hierarchyLevelSizeLimit Inherited number | undefined PresentationTreeDataProviderProps The limit for how many ECInstances should be loaded for a single hierarchy level.
imodel Inherited IModelConnection PresentationTreeDataProviderProps IModel to pull data from.
onHierarchyLimitExceeded Inherited () => void | undefined PresentationTreeDataProviderProps Callback for when the hierarchy limit is exceeded while loading nodes.
ruleDiagnostics Inherited { handler: ClientDiagnosticsHandler, severity?: DiagnosticsLoggerSeverity } | undefined PresentationTreeDataProviderProps Settings for capturing rule diagnostics.
ruleset Inherited string | Ruleset PresentationTreeDataProviderProps Id of the ruleset to use when requesting content or a ruleset itself.

Defined in

Last Updated: 17 December, 2024