UsePresentationTableProps<TColumn, TRow> Interface
Props for usePresentationTable hook.
Properties
Name | Type | Description | |
---|---|---|---|
columnMapper | (columns: TableColumnDefinition) => TColumn | Function that maps one column from generic TableColumnDefinition to table component specific type. | |
imodel | IModelConnection | iModel connection to pull data from. | |
keys | Readonly<KeySet> | Keys defining what to request data for. | |
pageSize | number | Paging size for obtaining rows. | |
rowMapper | (row: TableRowDefinition) => TRow | Function that maps one row from generic TableRowDefinition to table component specific type. | |
ruleset | string | Ruleset | Ruleset or ruleset id that should be used to load data. |
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.