useRulesetRegistration Function
Deprecated in 4.x. It is not compatible with React 18 StrictMode. Use Presentation.presentation.rulesets().add(ruleset)
directly.
Custom hook which registers supplied Ruleset on mount and removes on unmount.
useRulesetRegistration(ruleset: Ruleset): void
Parameter | Type | Description |
---|---|---|
ruleset | Ruleset |
Returns - void
Defined in
Last Updated: 06 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.