DisplayStyleProps Interface
JSON representation of a DisplayStyle or DisplayStyleState.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
jsonProperties | { styles?: DisplayStyleSettingsProps } | undefined | Display styles store their settings in a styles property within jsonProperties. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | DefinitionElementProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | DefinitionElementProps | The Code for this element |
federationGuid | string | undefined | DefinitionElementProps | A FederationGuid assigned to this element. |
id | string | undefined | DefinitionElementProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | DefinitionElementProps | A non-existent property used to discriminate between EntityProps and Entity. |
isPrivate | boolean | undefined | DefinitionElementProps | |
model | string | DefinitionElementProps | The Id of the Model containing this element |
parent | RelatedElementProps | undefined | DefinitionElementProps | The Parent of this element, if defined. |
userLabel | string | undefined | DefinitionElementProps | A user-assigned label for this element. |
Defined in
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.