getElementProps Method
Get properties of an Element by Id, FederationGuid, or Code
getElementProps<T extends ElementProps>(props: string | Code | ElementLoadProps): T
@throws IModelError if the element is not found or cannot be loaded.
@see IModelDb.Elements.tryGetElementProps
Parameter | Type | Description |
---|---|---|
props | string | Code | ElementLoadProps |
Returns - T
Defined in
- core/backend/src/IModelDb.ts Line 1765
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.