ElementLoadProps Interface
Parameters to specify what element to load for functions like IModelDb.Elements.getElementProps.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
code | CodeProps | undefined | The properties of the Code of the element to load. | |
federationGuid | string | undefined | ||
id | string | undefined |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayStyle Inherited | DisplayStyleLoadProps | undefined | ElementLoadOptions | Options controlling which properties of DisplayStyleProps to include or exclude. |
onlyBaseProperties Inherited | boolean | undefined | ElementLoadOptions | if true, only load the members of ElementProps, and no members from subclasses |
renderTimeline Inherited | RenderTimelineLoadProps | undefined | ElementLoadOptions | Options controlling which properties of RenderTimelineProps to include or exclude. |
wantBRepData Inherited | boolean | undefined | ElementLoadOptions | If true, include BRepEntity.DataProps.data in the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
wantGeometry Inherited | boolean | undefined | ElementLoadOptions | If true, include the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
Defined in
- core/common/src/ElementProps.ts Line 413
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.