ElementLoadOptions Interface
Options used to specify properties to include or exclude when querying ElementProps with functions like IModelDb.Elements.getElementProps and IModelConnection.Elements.loadProps.
Properties
Name | Type | Description | |
---|---|---|---|
displayStyle | DisplayStyleLoadProps | undefined | Options controlling which properties of DisplayStyleProps to include or exclude. | |
onlyBaseProperties | boolean | undefined | if true, only load the members of ElementProps, and no members from subclasses | |
renderTimeline | RenderTimelineLoadProps | undefined | Options controlling which properties of RenderTimelineProps to include or exclude. | |
wantBRepData | boolean | undefined | If true, include BRepEntity.DataProps.data in the GeometryStreamProps for GeometricElementProps and GeometryPartProps. | |
wantGeometry | boolean | undefined | If true, include the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
Defined in
- core/common/src/ElementProps.ts Line 391
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.