IModelError Class
The error type thrown by this module. Creating subclasses of IModelError should be avoided. Instead use ITwinError.
@see - ITwinError
- IModelErrorNumber for commonly-used error codes.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(errorNumber: number, message: string, getMetaData?: LoggingMetaData): IModelError |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_initName(): string Protected Inherited | BentleyError | This function returns the name of each error status. |
getMetaData(): undefined | object Inherited | BentleyError | get the meta data associated with this BentleyError, if any. |
BentleyError | Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists. |
|
getErrorMetadata(error: unknown): undefined | object Static Inherited | BentleyError | Use run-time type checking to safely get the metadata with an unknown error value, if possible. |
getErrorProps(error: unknown): ErrorProps Static Inherited | BentleyError | Returns a new ErrorProps object representing an unknown error value. |
getErrorStack(error: unknown): undefined | string Static Inherited | BentleyError | Use run-time type checking to safely get the call stack of an unknown error value, if possible. |
getMetaData(metaData: LoggingMetaData): undefined | object Static Inherited | BentleyError | get the metadata object associated with an ExceptionMetaData, if any. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
errorNumber Inherited | number | BentleyError | |
hasMetaData Accessor Inherited ReadOnly | boolean | BentleyError | Returns true if this BentleyError includes (optional) metadata. |
Defined in
- core/common/src/IModelError.ts Line 31
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.