NoContentError Class
Intended for API "no content" semantics where the error case should not trigger application failure monitoring systems.
Extends
Methods
Name | Description | |
---|---|---|
constructor(): NoContentError |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_initName(): string Protected Inherited | IModelError | This function returns the name of each error status. |
getMetaData(): undefined | object Inherited | IModelError | get the meta data associated with this BentleyError, if any. |
IModelError | Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists. |
|
getErrorMetadata(error: unknown): undefined | object Static Inherited | IModelError | Use run-time type checking to safely get the metadata with an unknown error value, if possible. |
getErrorProps(error: unknown): ErrorProps Static Inherited | IModelError | Returns a new ErrorProps object representing an unknown error value. |
getErrorStack(error: unknown): undefined | string Static Inherited | IModelError | Use run-time type checking to safely get the call stack of an unknown error value, if possible. |
getMetaData(metaData: LoggingMetaData): undefined | object Static Inherited | IModelError | get the metadata object associated with an ExceptionMetaData, if any. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
errorNumber Inherited | number | IModelError | |
hasMetaData Accessor Inherited ReadOnly | boolean | IModelError | Returns true if this BentleyError includes (optional) metadata. |
Defined in
- core/common/src/IModelError.ts Line 110
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.