ElementAspect Class

An Element Aspect is a class that defines a set of properties that are related to (and owned by) a single element. Semantically, an ElementAspect can be considered part of the Element. Thus, an ElementAspect is deleted if its owning Element is deleted. BIS Guideline: Subclass ElementUniqueAspect or ElementMultiAspect rather than subclassing ElementAspect directly.

Extends

Extended by

Methods

Name Description
constructor(props: ElementAspectProps, iModel: IModelDb): ElementAspect Construct an aspect from its JSON representation and its containing iModel.  
toJSON(): ElementAspectProps Obtain the JSON representation of this Entity.  
onDelete(arg: OnAspectIdArg): void Protected Static Called before an ElementAspect is deleted.  
onDeleted(_arg: OnAspectIdArg): void Protected Static Called after an ElementAspect was deleted.  
onInsert(arg: OnAspectPropsArg): void Protected Static Called before a new ElementAspect is inserted.  
onInserted(_arg: OnAspectPropsArg): void Protected Static Called after a new ElementAspect was inserted.  
onUpdate(arg: OnAspectPropsArg): void Protected Static Called before an ElementAspect is updated.  
onUpdated(_arg: OnAspectPropsArg): void Protected Static Called after an ElementAspect was updated.  

Inherited methods

Name Inherited from Description
collectReferenceIds(_referenceIds: EntityReferenceSet): void Protected Inherited Entity Collect the Ids of this entity's references at this level of the class hierarchy.
forEachProperty(func: PropertyCallback, includeCustom: booleantrue): void Inherited Entity Call a function for each property of this Entity.
getReferenceIds(): EntityReferenceSet Inherited Entity Get the set of this entity's entity references, EntityReferenceSet.
is(otherClass: ): boolean Static Inherited Entity return whether this Entity class is a subclass of another Entity class

Properties

Name Type Description
className Accessor Static ReadOnly string The name of the BIS class associated with this class.  
element RelatedElement    

Inherited properties

Name Type Inherited from Description
classFullName Accessor Inherited ReadOnly string Entity Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor Static Inherited ReadOnly string Entity Get the full BIS class name of this Entity in the form "schema:class"
className Accessor Inherited ReadOnly string Entity The name of the BIS class associated with this class.
id Inherited string Entity The Id of this Entity.
iModel Inherited IModelDb Entity The IModelDb that contains this Entity
isInstanceOfEntity Readonly Inherited "true" Entity An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
schema Static Inherited Entity The Schema that defines this class.
schemaName Accessor Inherited ReadOnly string Entity The name of the BIS Schema that defines this class

Defined in

Last Updated: 14 November, 2024